Assignment Group isnt being set when using Advanced Creation script

When I have Advanced Creation checked for an Incident creation rule, the Assignment group is not set on Incidents created from the rule. I have filled in the correct assignment group in the script as below

Cause

The Assignment group accepts the Sys_ID of an Assignment Group only and doesn't look up the sys_ID from its name. Provide the Sys_ID of the assignment group when setting up the script

Workaround

  1. In the navbar of ServiceNow, search for Group

  2. Go to User Administration > Groups (if you do not see this option you don't have permissions and will need to contact a ServiceNow administrator to complete these steps)

  3. Find the group you want to find the Sys_ID of

  4. Right-click the grey bar at the top of the central pane and select copy Sys_Id

  5. Go back to your Incident Creation Rule to the Advanced Creation script

  6. Paste the Sys_ID into the script following the below syntax and save the Incident Creation Rule

	grInc.assignment_group = "a715cd759f2002002920bde8132e7018";