Creation rule fails to create Task, Catalog Task, and Service Task

Added in v2.0.0.0

Problem

When a new SCOM alert comes in, a creation rule set to create a Task, Catalog Task, or Service Task fails to raise a task of this type

Cause

By default ServiceNow does not provide users or the ITIL role with access to these tables. You may find that there are not ACL entries for these roles or you may find that there are not any ACL entries for those tables at all…

Resolution

Provide the Service account with appropriate access to these tables to use these task types. For example you could provide the ‘catalog_admin' role to the service account to provide access to create Catalog Tasks. Similarly you could create your own ACL to provide access to the required table via the 'x_oklt_cookdown_sc.scom_sync_service’ role or another role of your choice.